App is needed to use this device

Good morning,

When I attempt to pair the EKGraph to my android galaxy 9+ phone, it says "an app is needed to use this device " and therefore, does not get paired.

Anyone else experience this bug? What was your solution? Needless to say, it can be frustrating.

Thanks,
Peter

Have you installed the sonohealth app from the App Store?

Yes. App is installed from day one. It appears as though although the message comes up, I’m still able to connect.